Legacy Platforms

Most organizations have apps running on platforms that are no longer supported such as Java, Apache Tomcat and WebLogic. In fact the most widely used version of Java is not the most current. That’s because it’s too risky and expensive in most cases to rewrite an app’s code, despite known and unknown vulnerabilities across the entire software stack.

Waratek protects your applications, no matter what version of Java you use with an easy to install .JAR file plugin, offering the advantages of a Java 8 virtual host container for legacy Java apps running in guest mode for Java 4, 5, 6 or 7.

After installation of the Waratek solution, identified vulnerabilities are mitigated:

  • Without code changes
  • Without prior knowledge of the application
  • Without slowing the app’s performance

Java Versions Used

SOURCE: Plumbr Dec 31, 2015

Java 6

Java 7

Java 8

Before Waratek

Exposed Vulnerabilities




After Waratek

Completely Mitigated Application




SUGGESTED VIEWING:

Watch this short video to find out how Waratek secures Legacy Java

PLAY VIDEO

SUGGESTED READING:

Legacy Java and PCI Compliance

DOWNLOAD TEST CASE

Try A Demo
& Get Protected.

Get a 30 day free trial when you schedule now.